Subject: pkg/23609: devel/bonobo needs converters/libiconv/
To: None <>
From: None <>
List: netbsd-bugs
Date: 12/01/2003 20:32:43
>Number:         23609
>Category:       pkg
>Synopsis:       devel/bonobo needs converters/libiconv/
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Dec 01 19:35:00 UTC 2003
>Release:        NetBSD 1.6.1
System: NetBSD tri 1.6.1 NetBSD 1.6.1 (TRI) #6: Sun Nov 2 18:10:02 CET 2003 root@tri:/usr/src/sys/arch/i386/compile/TRI i386
Architecture: i386
Machine: i386
	On August 4 I have built bonobo-1.0.18nb5 without any trouble.
	bonobo-1.0.18nb5 did not need converters/libiconv/

	But after pkgsrc switched to bonobo-1.0.18nb6 on November 16,
	my first attempt to rebuild it failed. There was a link problem at
	build. I then found that libiconv was required and fixed my Makefile.
	I don't understand why bonobo started requiring libiconv, but I can
	tell that I have successfully built bonobo-1.0.18nb6 with my patch
	as well as a few other packages that require bonobo : gal-0.22nb3,
	soup-0.7.10nb6, gtkhtml-1.1.10nb1, p5-Gdk-Pixbuf-0.7008nb2 and

	cd pkgsrc/devel/bonobo ; make
	.include "../../converters/libiconv/"
	in pkgsrc/devel/bonobo/Makefile.