Subject: pkg/23570: devel/atk should depend on gettext-lib instead of libiconv
To: None <>
From: Min Sik Kim <>
List: netbsd-bugs
Date: 11/25/2003 14:37:18
>Number:         23570
>Category:       pkg
>Synopsis:       devel/atk should depend on gettext-lib instead of libiconv
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Nov 25 20:38:01 UTC 2003
>Originator:     Min Sik Kim
>Release:        NetBSD 1.6ZF
System: NetBSD 1.6ZF NetBSD 1.6ZF (MIKE) #8: Sat Nov 22 02:01:55 CST 2003 i386
Architecture: i386
Machine: i386
devel/atk includes converters/libiconv/ in its Makefile.
Because atk itself doesn't use iconv, this should be removed.
Instead, including devel/gettext-lib would take care of libiconv

Index: Makefile
RCS file: /cvsroot/pkgsrc/devel/atk/Makefile,v
retrieving revision 1.20
diff -u -r1.20 Makefile
--- Makefile	2003/08/27 09:17:25	1.20
+++ Makefile	2003/11/25 20:21:37
@@ -26,8 +26,8 @@
 # glib-mkenums overflows a 2048kb stack on atkobject.h
+.include "../../devel/gettext-lib/"
 .include "../../devel/glib2/"
 .include "../../devel/pkgconfig/"
-.include "../../converters/libiconv/"
 .include "../../mk/"
RCS file: /cvsroot/pkgsrc/devel/atk/,v
retrieving revision 1.8
diff -u -r1.8
---	2003/11/25 12:21:27	1.8
+++	2003/11/25 20:21:37
@@ -18,8 +18,8 @@
 BUILDLINK_FILES.atk+=	include/atk-1.0/*
 BUILDLINK_FILES.atk+=	lib/libatk-1.0.*
+.include "../../devel/gettext-lib/"
 .include "../../devel/glib2/"
-.include "../../converters/libiconv/"
 BUILDLINK_TARGETS+=	atk-buildlink