Subject: pkg/23476: Cannot build MesaLib 5.0.2
To: None <>
From: None <>
List: netbsd-bugs
Date: 11/18/2003 14:14:40
>Number:         23476
>Category:       pkg
>Synopsis:       Cannot build MesaLib 5.0.2
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Nov 18 14:15:01 UTC 2003
>Originator:     Dave Ockwell-Jenner
>Release:        1.6.1
Solar Nexus Solutions
NetBSD mcunix 1.6.1 NetBSD 1.6.1 (GENERIC) #0: Tue Apr  8 15:07:52 UTC 2003 macppc
/usr/pkgsrc updated via CVS.  Several packages have a dependency on MesaLib.  When attempting to build MesaLib, get the following error:-

=> Checksum mismatch for MesaLib-5.0.2.tar.bz2.
Make sure the Makefile and checksum file (/usr/pkgsrc/graphics/MesaLib/distinfo)
are up to date.  If you want to override this check, type
"make NO_CHECKSUM=yes [other args]".
*** Error code 1

If doing a 'make NO_CHECKSUM=yes', get:-

===> Extracting for MesaLib-5.0.2nb1
===> Required installed package automake>=1.7: automake-1.7.6 found
===> Required installed package autoconf>=2.50: autoconf-2.57 found
===> Required installed package libtool-base>=1.4.20010614nb11: libtool-base-1.4.20010614nb16 found
===> Required installed package x11-links>=0.17: x11-links-0.18 found
===> Required installed package gmake>=3.78: gmake-3.80nb2 found
===> Patching for MesaLib-5.0.2nb1
cd /usr/pkgsrc/graphics/MesaLib/work/Mesa-5.0.2 && /usr/pkg/bin/aclocal-1.7 && /usr/pkg/bin/automake-1.7
src/GGI/ INCLUDES must be set with `=' before using `+='
*** Error code 1
Run 'make' in /usr/pkgsrc/graphics/MesaLib.
Not known.