Subject: port-i386/23145: No ESS1879 detection in 1.6.1 or -current
To: None <>
From: Swift Griggs <>
List: netbsd-bugs
Date: 10/13/2003 02:08:15
>Number:         23145
>Category:       port-i386
>Synopsis:       No ESS1879 detection in 1.6.1 or -current
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    port-i386-maintainer
>State:          open
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Mon Oct 13 08:09:00 UTC 2003
>Release:        NetBSD 1.6

System: NetBSD 1.6 NetBSD 1.6 (SABRE) #1: Wed Aug 13 18:47:05 MDT 2003 i386
Architecture: i386
Machine: i386

	The ESS 1879 audio chipset is not configured by the NetBSD kernel. I
    have tried both 1.6.1_STABLE and also -current as of 10/10/2003. I am
    using a Hewlett Packard Omnibook Sojourn which has this chipset built in
    as a pnpisa device. The Japanese Mitsubishi Pedion is identical to this
    laptop. The manufacturer is, in fact, Mitsubishi. The audio interface
    has a plug 'n play ID string of "ESS1879". The laptop is rather old
    (233MMX Pentium). The only freeware drivers I know of are those for
    FreeBSD and the Linux ALSA drivers. The chipset is full-duplex and mmap
    capable and should work with a standard 18XX series driver. I tried
    editing the isapnpdevs file in /usr/src/sys/dev/isapnp and also the
    strings in ess_pnpbios.c located in
    /usr/src/sys/arch/i386/pnpbios but it would appear that more work is
    needed to get it working. Thanks for looking!
    Get an HP Sojourn and try to use the ESS 1879 audio device. 
	I wish I knew how to fix it and I could send a patch!