Subject: pkg/23141: failed on typo
To: None <>
From: None <>
List: netbsd-bugs
Date: 10/13/2003 00:06:15
>Number:         23141
>Category:       pkg
>Synopsis: failed on typo
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Oct 13 00:07:00 UTC 2003
>Originator:     Bas van Oostveen
>Release:        pkgsrc for irix
IRIX washu 6.5 6.5.17m 07121149 IP32
>Description: 134 containts the following error

running pkg_chk -i (or any other package tool)

bmake: "/usr/pkgsrc/pkgtools/pkgchk/../../mk/" line 134: Need an operator
bmake: "../../mk/../../mk/" line 425: if-less endif
bmake: "../../mk/../../mk/" line 425: Need an oprator
bmake: Fatal errors encountered -- cannot continue

this all is cased by a very small type on line 134 of in pkgsrc-current.

the .if defined(_OPSYS_GPATCH_REQD) && ${_OPSYS_GPATCH_REQD} == "YES"
doesnt start with a . at shown above

vi /usr/pkgsrc/mk/

(or just at a "." in front of line 134 :)