Subject: pkg/21989: kdevelop QTt-Project-Templates may need patching
To: None <>
From: None <>
List: netbsd-bugs
Date: 06/25/2003 16:02:20
>Number:         21989
>Category:       pkg
>Synopsis:       kdevelop generates Qt-Project-Templates that don't work under NetBSD
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jun 25 14:04:00 UTC 2003
>Originator:     Rene Schickbauer
>Release:        NetBSD 1.6.1 pkgsrc-current from 21.Junde 2003
System: NetBSD gandalf 1.6.1 NetBSD 1.6.1 (GENERIC) #0: Tue Apr 8 12:05:52 UTC 2003 i386
Architecture: i386
Machine: i386
When generating a Qt-Project from template-files (Project->New) the generated Framework-classes don't
compile under NetBSD, but give the following error: error: m4_popdef: undefined macro: AC_Dest 
autoconf/status.m4:844: AC_CONFIG_FILES is expanded from... the top level 
autom4te: /usr/pkg/bin/gm4 failed with exit status: 1 
gmake[1]: *** [cvs] Error 1 
gmake: *** [all] Error 2 
*** failed *** 

This seems to be related to an autoconf/automake problem similar to that kdevelop had in the pkgsrc-1.6.1 tree.

Open kdevelop, select "Project/New..." and choose "Qt SDI" as project type. Continue the wizard to the end
and let kdevelop create the project file -> it should fail.
I'm not sure (i'm not an export on automake) but it seems that the templates need some patching...