Subject: pkg/21876: lang/python15 not building; missing -lnet
To: None <>
From: None <>
List: netbsd-bugs
Date: 06/13/2003 14:19:35
>Number:         21876
>Category:       pkg
>Synopsis:       lang/python15 not building; missing -lnet
>Confidential:   yes
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Fri Jun 13 21:20:00 UTC 2003
>Release:        NetBSD 1.6
System: NetBSD 1.6 NetBSD 1.6 (JCR-20020927) #3: Sat Sep 28 13:40:20 PDT 2002 i386
Architecture: i386
Machine: i386
finance/emma wants python 1.5.
lang/python15 won't build:

cc -g -O2 pgenmain.o acceler.o grammar1.o  listnode.o node.o parser.o  parsetok.
o tokenizer.o bitset.o  metagrammar.o firstsets.o grammar.o pgen.o printgrammar.
o -lnet -o pgen
/usr/bin/ld: cannot find -lnet
collect2: ld returned 1 exit status

For some reason, LDFLAGS is not included in that Makefile.
cd pkgsrc/lang/python15
Using buildlink2 with libnet didn't help either.

If -lnet is libnet, then a dependency or the buildlink2 for it should be used.

My workaround was to change Python-1.5.2/Parser/Makefile
so LIBS include LDFLAGS.

I don't know why it was not included in first place.