Subject: pkg/21258: lyx and magicfilter can't co-exist
To: None <>
From: None <>
List: netbsd-bugs
Date: 04/22/2003 07:45:46
>Number:         21258
>Category:       pkg
>Synopsis:       lyx and magicfilter require incompatible versions of teTeX
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Tue Apr 22 11:46:01 UTC 2003
>Originator:     Steven M. Bellovin
>Release:        NetBSD 1.6R
System: NetBSD 1.6R NetBSD 1.6R (CHALLENGER) #0: Sat Apr 19 10:31:33 EDT 2003 i386
Architecture: i386
Machine: i386
	The current Makefile for lyx-qt depends on teTeX2.  The
	Makefile for magicfilter depends on teTeX.  Both can't
	be installed simultaneously.  Either magicfilter's Makefile
	should be updated, some way should be found to let the two
	teTeX variants to co-exist, or the Makefiles should depend on
	some version-agnostic type.  (A quick grep suggests that
	skampi, cweb, doxygen, pvs, TeXmacs, xdvipresent, yplot,
	octave, pari, latex2html, texi2html, and p5-Template-Toolkit
	would have a similar clash with lyx.)
	Try to build and install the two packages on the same machine...