Subject: pkg/21197: several packages install #!/usr/bin/perl scripts
To: None <>
From: None <>
List: netbsd-bugs
Date: 04/15/2003 16:17:00
>Number:         21197
>Category:       pkg
>Synopsis:       several packages install /usr/bin/perl scripts
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Apr 15 21:29:00 UTC 2003
>Originator:     Nathan J. Williams
>Release:        NetBSD 1.6R
	Wasabi Systems, Inc.
System: NetBSD 1.6R NetBSD 1.6R (MARVIN) #52: Tue Apr 15 15:16:25 EDT 2003 i386
Architecture: i386
Machine: i386

Poking around for useful SMB tools after installing samba, I
tried to run /usr/pkg/bin/findsmb, only to discover that it is a
script that starts with "#!/usr/bin/perl". Since perl is installed in
/usr/pkg/bin/perl, the script doesn't work.

Here is the set of offenders I found by grepping for /usr/bin/perl in

audio/nas-1.6nb1:		/usr/pkg/bin/auscope
audio/kdemultimedia-3.1:        /usr/pkg/bin/
editors/emacs-21.3nb1: 		/usr/pkg/bin/emacs-grep-changelog
graphics/libungif-  	/usr/pkg/bin/gifburst
net/kdenetwork-3.1: 		/usr/pkg/bin/dsirc
net/samba-2.2.8a:   		/usr/pkg/bin/findsmb
print/ghostscript-6.01nb4:  	/usr/pkg/bin/
x11/kdebase-3.1: 		/usr/pkg/bin/filesharelist
x11/kdelibs-3.1:        	/usr/pkg/bin/preparetips


Try to run one of the above scripts; debug the usual annoying "Command
not found" interpreter-missing error.


None supplied.