Subject: pkg/21115: libtool update to 1.4.3
To: None <>
From: None <>
List: netbsd-bugs
Date: 04/12/2003 23:55:59
>Number:         21115
>Category:       pkg
>Synopsis:       libtool update to 1.4.3
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sat Apr 12 14:57:00 PDT 2003
>Originator:     Marc Recht
>Release:        NetBSD 1.6R
System: NetBSD 1.6R NetBSD 1.6R (LEELOO) #0: Sat Apr 12 21:17:49 CEST 2003 i386
Architecture: i386
Machine: i386
Update of devel libtool to 1.4.3. 

ATM I haven't got the opportunity to test it under any other OS/version than 1.6R,
but on 1.6R it seems to work fine.

I guess the old libtool was a version somewhere between 1.4 and 1.4.1,
the the changes are approx.:

New in 1.4.3: 2002-10-13; CVS version 1.4.2a, Robert Boehne:
* The libltdl subdirectory now bootstraps correctly with Automake 1.5.
* srcdir != builddir builds with Automake 1.5 work correctly.
* Support for mips-compaq-nonstopux.
* New command line argument, --preserve-dup-deps prevents removal of
  duplicate dependent libraries.
New in 1.4.2: 2001-09-11; CVS version 1.4.1a, Gary V. Vaughan:
* libltdl now builds on solaris again
* diagnose and warn about not-quite-working combinations of gcc and
  ld on solaris.
* Improved OpenBSD support.
* Improved cygwin support.
* Bugfixes.
New in 1.4.1: 2001-09-03; CVS version 1.4.0a, Libtool team:
* Better error messages from libltdl when loading fails.
* Don't leave here-doc files behind.
* Improved support for OpenBSD.
* Libtool will build with autoconf-2.50 and higher.
* Plug memory management bugs in libltdl.
* Prefer shl_load to dlopen for better operation on HP-UX.