Subject: pkg/20922: curses-based dopewars game can't build without X
To: None <>
From: David W. Talmage <>
List: netbsd-bugs
Date: 03/28/2003 11:45:40
>Number:         20922
>Category:       pkg
>Synopsis:       dopewars 1.5.8 can't compile on X-less systems
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Fri Mar 28 08:46:01 PST 2003
>Originator:     David W. Talmage
>Release:        NetBSD 1.6
/~\ The ASCII                     David W. Talmage
\ / Ribbon Campaign     
 X  Against HTML
/ \ Email!
System: NetBSD 1.6 NetBSD 1.6 (MADISON) #1: Sun Oct 20 14:24:48 EDT 2002 i386
Architecture: i386
Machine: i386
dopewars depends on gnome1-dirs, which depends on X.

Removing the dependency on gnome1-dirs reveals that there is more to
it than that.  Something in the makefile is broken: ld can't find
libiconv even though it is installed.

        cd /usr/pkgsrc/games/dopewars
Part of the fix may be to remove the DEPENDS line from the Makefile:

DEPENDS+=               gnome1-dirs>=1.0:../../misc/gnome1-dirs

Then make can configure and begin building dopewars.  This doesn't entirely fix the problem, alas:

mkdir .libs
cc -O2 -I/usr/pkg/include -Wall -Wl,-R/usr/pkg/lib -o dopewars admin.o AIPlayer.o util.o configfile.o convert.o dopewars.o error.o log.o message.o network.o serverside.o sound.o tstring.o winmain.o -Wl,-R/usr/pkg/lib  -L/usr/pkg/lib curses_client/libcursesclient.a cursesport/libcursesport.a /usr/pkg/lib/ /usr/pkg/lib/ /usr/pkg/lib/ /usr/pkg/lib/ -lc -Wl,--rpath -Wl,/usr/pkg/lib -Wl,--rpath -Wl,/usr/pkg/lib
/usr/bin/ld: cannot find -liconv
collect2: ld returned 1 exit status
gmake[3]: *** [dopewars] Error 1
gmake[3]: Leaving directory `/home/pkgsrc/games/dopewars/work/dopewars-1.5.8/src'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/home/pkgsrc/games/dopewars/work/dopewars-1.5.8/src'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/home/pkgsrc/games/dopewars/work/dopewars-1.5.8'
gmake: *** [all] Error 2
*** Error code 2

I also tried removing the X11 dependency from gnome1-dirs and
gnome-dirs.  Then I installed both of them and tried to build
dopewars.  The same complaint from ld arose.