Subject: pkg/20920: gimp-print-lib needs a lex to build
To: None <>
From: None <>
List: netbsd-bugs
Date: 03/28/2003 06:41:35
>Number:         20920
>Category:       pkg
>Synopsis:       gimp-print-lib needs a lex to build
>Confidential:   yes
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Fri Mar 28 06:42:00 PST 2003
>Release:        NetBSD 1.6
System: NetBSD 1.6 NetBSD 1.6 (JCR-20020927) #3: Sat Sep 28 13:40:20 PDT 2002 i386
Architecture: i386
Machine: i386
gimp-print-lib needs a lex to build.
Try to build print/gimp-print-lib without flex installed.
This may not be the right fix. It should probably check for a lex too.
This worked for me. Maybe something like BUILD_USES_LEX or
BUILD_USES_FLEX would be okay to create.

diff -b -u -r1.8 Makefile
--- print/gimp-print-lib/Makefile	2002/11/27 16:12:36	1.8
+++ print/gimp-print-lib/Makefile	2003/03/28 14:38:02
@@ -10,6 +10,10 @@
 COMMENT=	drivers for Canon, Epson, Lexmark, and PCL printers
+.if !exists(/usr/bin/flex)
+BUILD_DEPENDS+=		flex-[0-9]*:../../devel/flex
 USE_GMAKE=		yes