Subject: pkg/20901: pkgsrc/devel/SDL/ needs higher version
To: None <>
From: None <>
List: netbsd-bugs
Date: 03/27/2003 00:13:33
>Number:         20901
>Category:       pkg
>Synopsis:       SDL-image needs SDL 1.2.4.
>Confidential:   yes
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 27 00:14:01 PST 2003
>Release:        NetBSD 1.6
System: NetBSD 1.6 NetBSD 1.6 (JCR-20020927) #3: Sat Sep 28 13:40:20 PDT 2002 i386
Architecture: i386
Machine: i386
pkgsrc/graphics/SDL-image needs SDL >= 1.2.4
but the pkgsrc/devel/SDL/ has
Attempt to build SDL_image with SDL-1.2.3nb2 installed.
You may get an error like:

checking for SDL - version >= 1.2.4... 
*** 'sdl-config --version' returned 1.2.3, but the minimum version
*** of SDL required is 1.2.4. If sdl-config is correct, then it is
*** best to upgrade to the required version.
*** If sdl-config was wrong, set the environment variable SDL_CONFIG
*** to point to the correct copy of sdl-config, and remove the file
*** config.cache before re-running configure
configure: error: *** SDL version 1.2.4 not found!
*** Error code 1

Change pkgsrc/devel/SDL/ so