Subject: Re: pkg/20683: Update to Ruby 1.6.8
To: Takahiro Kambe <>
From: Jonathan Perkin <>
List: netbsd-bugs
Date: 03/13/2003 16:12:58
* On 2003-03-13 at 16:09 GMT, Takahiro Kambe wrote:

> libruby.MAJORMINOR.TEENY has borrowed from FreeBSD ports.  Since
> ruby's shared library dosen't (uppper) binary compatible, shared
> library's major version should be differ.  That's the reason why I
> choosed FreeBSD ports scheme.

Ok, fair enough - I guess we'll just need to patch for every system we
plan to support in pkgsrc.

> >  3) It requires the patch I posted on the above tech-pkg thread to
> >     truly complete the Solaris PLIST fix.
> Would you please tell me which thread it was?

Currently just my post, as nobody has replied:

 Message-Id: <>

The patch is also in this PR.


Jonathan Perkin - Internet Operations Engineer - BBC Internet Services
24x7 Hotline: +44 (0)1628 407 777 (x37777) -