Subject: pkg/20476: need LIBTOOL=libtool to build graphics/jpeg
To: None <>
From: None <>
List: netbsd-bugs
Date: 02/23/2003 18:14:36
>Number:         20476
>Category:       pkg
>Synopsis:       need LIBTOOL=libtool to build graphics/jpeg
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Feb 23 18:15:01 PST 2003
>Originator:     Andrew Cagney
>Release:        1.6, pkgsrc snap downloaded yesterday
NetBSD localhost 1.6 NetBSD 1.6 (NETLUX) #0: Thu Feb  6 11:11:16 EST 2003     boor@localhost:/usr/old/sys/arch/macppc/compile/NETLUX macppc

When building graphics/jpeg, it tries to run ./libtool.  That doesn't exist.  'make LIBTOOL=libtool' gets around the problem.

cagney@nettle$ pwd
cagney@nettle$ make
=> Checksum OK for jpegsrc.v6b.tar.gz.
===> Extracting for jpeg-6b
===> Required installed package libtool-base>=1.4.20010614nb11: libtool-base-1.4.20010614nb13 found
===> Patching for jpeg-6b
===> Buildlinking for jpeg-6b
===> Configuring for jpeg-6b
===> Building for jpeg-6b
./libtool --mode=compile cc -O2 -I/usr/pkg/include   -I/usr/pkg/include -I. -c ./jcapimin.c
./libtool: not found