Subject: port-macppc/20416: wi timeout problems on macppc
To: None <>
From: None <>
List: netbsd-bugs
Date: 02/18/2003 20:22:27
>Number:         20416
>Category:       port-macppc
>Synopsis:       wi timeout problems on macppc
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    port-macppc-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Feb 18 11:24:00 PST 2003
>Originator:     Thomas Klausner
>Release:        NetBSD 1.6N
System: NetBSD kraftlackel 1.6N NetBSD 1.6N (KRAFTLACKEL) #0: Mon Feb 17 17:38:00 CET 2003     wiz@kraftlackel:/usr/src/sys/arch/macppc/compile/KRAFTLACKEL macppc
Architecture: powerpc
Machine: macppc
I have the following hardware:
cbb0 at pci0 dev 19 function 0: Texas Instruments PCI1211 PCI-CardBus Bridge (rev. 0x00)
cbb0: interrupting at irq 22
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 1 device 0
pcmcia0 at cardslot0
wi0 at pcmcia0 function 0: NETGEAR MA401RA Wireless PC, Card, ISL37300PEval-RevA
wi0: 802.11 address 00:09:5b:34:fa:07
wi0: using RF:PRISM2.5 MAC:ISL3873B(PCMCIA)
wi0: Intersil Firmware: Primary (1.0.7), Station (1.3.6)
wi0: supported rates: 1Mbps 2Mbps 5.5Mbps 11Mbps

When scp'ing files from the machine via wi0, frequent timeouts occur:
	wi0: device timeout
They occur after every 200-400KB of transferred data, which makes
copying files from the machine very slow.

scp _to_ the machine works fine, no timeouts.

A second Netgear MA401RA from the same series shows the same symptoms;
I have no other wireless cards to test with.
Configure wireless; scp a file (some MB at least to see it easily)
to a different machine via the wi interface. The problem occurs in
both adhoc and infrastructure mode.
Perhaps missing interrupts in the cardbus driver?