Subject: pkg/20401: finance/gnucash has an implicit build dependency on devel/pkgconfig
To: None <>
From: Eric Schnoebelen <>
List: netbsd-bugs
Date: 02/17/2003 17:40:25
>Number:         20401
>Category:       pkg
>Synopsis:       finance/gnucash has an inplicit build dependency on devel/pkgconfig
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Feb 17 17:33:00 PST 2003
>Originator:     Eric Schnoebelen
>Release:        NetBSD 1.6_STABLE
Eric Schnoebelen
          Programming is the art of debugging a blank sheet of paper.
System: NetBSD egsner 1.6_STABLE NetBSD 1.6_STABLE (GENERIC) #23: Tue Jan 7 22:23:54 CST 2003 root@egsner:/work/eric/NetBSD-1.6/obj/i386/sys/arch/i386/compile/GENERIC i386
Architecture: i386
Machine: i386
	After updating pkgsrc (20031115), and trying to update libtool,
I found that (besides half the world wanting to rebuild)
finance/gnucash has an implicit dependency on devel/pkgconfig.  

This dependency is from the patch to configure, which uses pkgconfig to
get the path to libgtkhtml-1.1

	[see above/}
	Add an explicit build dependency either to gnucash, or to one of
the buildlink files it includes.