Subject: pkg/20355: make update deoesn't find installed packages
To: None <gnats-bugs@gnats.netbsd.org>
From: None <franklin@elfie.org>
List: netbsd-bugs
Date: 02/15/2003 11:26:50
>Number:         20355
>Category:       pkg
>Synopsis:       make update deoesn't find installed packages
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Feb 15 08:27:00 PST 2003
>Closed-Date:
>Last-Modified:
>Originator:     John Franklin
>Release:        NetBSD 1.6N
>Organization:
John Franklin
franklin@elfie.org
ICBM: 3543'56"N 7853'27"W
>Environment:
	
	
System: NetBSD deathmitten 1.6N NetBSD 1.6N (DM.ACPI) #0: Fri Feb 14 15:09:47 EST 2003 franklin@deathmitten:/usr/src2/sys/arch/i386/compile/DM.ACPI i386
Architecture: i386
Machine: i386
>Description:
Make update does not find installed packages with system upgraded to 
-current as of 14 Feb 2003.
	
>How-To-Repeat:

deathmitten# pwd
/usr/src/pkgsrc/devel/glib
deathmitten# pkg_info glib
Information for glib-1.2.10nb3:

Comment:
Some useful routines for C programming

Description:
GLib is a library which includes routines for C, providing lists,
trees, hashes, memory allocation functionality and many other things.

Versions of GLib prior to 1.1.0 are distributed with GTK+ versions 1.1.0
and earlier.

A mailing list is located at:
  gtk-list@redhat.com

Homepage:
http://developer.gnome.org/doc/API/glib/index.html


deathmitten# make update
pkg_info: No matching pkg for glib-[0-9]*.
=> Checksum OK for glib-1.2.10.tar.gz.
===> Extracting for glib-1.2.10nb3
===> Required installed package libtool-base>=1.4.20010614nb11: libtool-base-1.4.20010614nb13 found

	
>Fix:
	
>Release-Note:
>Audit-Trail:
>Unformatted: