Subject: pkg/19995: devel/ncurses/ lacks _INCOMPAT_CURSES defaults for various OSes
To: None <>
From: Lubomir Sedlacik <>
List: netbsd-bugs
Date: 01/22/2003 12:21:22
	Note: There was a bad value `non-criticald' for the field `>Severity:'.
	It was set to the default value of `serious'.

>Number:         19995
>Category:       pkg
>Synopsis:       devel/ncurses/ lacks _INCOMPAT_CURSES defaults for various OSes
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jan 22 03:22:00 PST 2003
>Originator:     Lubomir Sedlacik
>Release:        NetBSD 1.6_STABLE

it might be appropriate to add reasonable defaults for OSes other than NetBSD
and Solaris and define _INCOMPAT_CURSES for them if needed and don't force
dependency on ncurses unless really necessary.

i am going to review all packages with USE_NCURSES soon to check whether they
really need this for 1.6M and later (e.g. after halfdelay() addition as
textproc/aspell was already modified) and remove it where appropriate.

this might trigger some problems on other OSes using pkgsrc so i encourage
people working on pkgsrc support for these systems to set _INCOMPAT_CURSES as


devel/ncurses/ inspection.