Subject: pkg/20161: kdebase3 appears to have some outdated patches
To: None <>
From: None <>
List: netbsd-bugs
Date: 01/19/2003 21:58:18
>Number:         20161
>Category:       pkg
>Synopsis:       kdebase3 fails to build due to bad patches
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Feb 01 19:32:01 PST 2003
>Originator:     David Forrai
>Release:        NetBSD 1.6_STABLE
System: NetBSD 1.6_STABLE NetBSD 1.6_STABLE (DPFPC) #0: Sun Jan 12 21:36:39 EST 2003 root@:/usr/src/sys/arch/i386/compile/DPFPC i386
Architecture: i386
Machine: i386
	There were two "bad" patches in pkgsrc-current dated 4 Jan 2003
	(or there about).  One (I don't remember which) appeared to just
	have an invalid patch checksum.  The other, patch-eq, appeared to
	be left over from a previous kdebase3 package as a similar fix
	appeared to be incorporated into the source file.
	# cd /usr/pkgsrc/x11/kdebase3
	# make
	I removed patch-eq from the patches subdirectory and ran 
	# make makepatchsum