Subject: lib/19921: openldap doesn't work with native NetBSD pthreads
To: None <>
From: None <>
List: netbsd-bugs
Date: 01/19/2003 03:49:44
>Number:         19921
>Category:       lib
>Synopsis:       openldap fails to compile due to missing pthread function
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    lib-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jan 18 19:48:00 PST 2003
>Release:        NetBSD 1.6M
System: NetBSD 1.6M NetBSD 1.6M (PINKY) #12: Sun Jan 19 01:22:11 GMT 2003 i386
Architecture: i386
Machine: i386
While attempting a kde3 build on -current (post SA merge) I couldn't build openldap, the error is:
cc -O2 -I/extra2/obj/pkgsrc/databases/openldap/work.pinky/.buildlink/include -I../../include -I../../include -DLDAP_R_COMPILE -I./../libldap -I/extra2/obj/pkgsrc/databases/openldap/work.pinky/.buildlink/include -Wl,-R/usr/pkg/lib -o .libs/apitest apitest.o  -L/extra2/obj/pkgsrc/databases/openldap/work.pinky/openldap-2.0.27/libraries -L/extra2/obj/pkgsrc/databases/openldap/work.pinky/.buildlink/lib /extra2/obj/pkgsrc/databases/openldap/work.pinky/openldap-2.0.27/libraries/libldap_r/.libs/ -llber -llutil -lssl -lcrypto -lcrypt -lpthread -Wl,--rpath -Wl,/usr/pkg/lib
/extra2/obj/pkgsrc/databases/openldap/work.pinky/openldap-2.0.27/libraries/libldap_r/.libs/ undefined reference to `pthread_attr_setstacksize'
*** Error code 1

Note these things are to be expected in a fresh new world of threads, but I just wanted this flagged so we can see what effects this will have.  This is more a note of something, as such everything else I've tried has worked 8)

cd pkgsrc/databases/openldap
implement pthread_attr_setstacksize.