Subject: pkg/19777: [PATCH] Apps can't link with libgtop2 without libXau
To: None <>
From: Eric Gillespie <>
List: netbsd-bugs
Date: 01/11/2003 02:26:11
>Number:         19777
>Category:       pkg
>Synopsis:       [PATCH] Apps can't link with libgtop2 without libXau
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Jan 10 23:28:00 PST 2003
>Release:        NetBSD 1.6
System: NetBSD 1.6 NetBSD 1.6 ($Id: WUNDAGORE 435 2002-10-02 02:08:24Z epg $) #4: Sun Nov 24 15:22:10 EST 2002 i386
Architecture: i386
Machine: i386
I discovered this bug while preparing a package for
gnome-system-monitor.  libgtop2's .la file lists libXau as a
dependency, but that doesn't help applications which don't use
libtool to link.  This patch adds -lXau to the Libs in the
pkgconfig file.
Install this patch:


---	Mon Jun 10 16:34:52 2002
@@ -7,7 +7,7 @@ Name: libgtop
 Description: Portable System Access Library
 Requires: glib-2.0
 Version: @VERSION@
-Libs: -L${libdir} @LIBGTOP_LIBS@
+Libs: -Wl,-R${libdir} -L${libdir} @LIBGTOP_LIBS@ @LIBGTOP_EXTRA_LIBS@
 Cflags: -I${includedir}/libgtop-2.0