Subject: pkg/19365: courier-auth packager & vpopmail problem
To: None <>
From: None <>
List: netbsd-bugs
Date: 12/12/2002 15:58:36
>Number:         19365
>Category:       pkg
>Synopsis:       package compilation error (courier-auth & vpopmail)
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Dec 12 07:59:00 PST 2002
>Originator:     Pawel Marzec
>Release:        NetBSD 1.6J
System: NetBSD s03 1.6J NetBSD 1.6J ( #3: Mon Nov 4 11:58:51 CET 2002 root@s02:/usr/src/sys/arch/i386/compile/ i386
Architecture: i386
Machine: i386
	There is a problem during compilation of mail/courier-auth package when in system is installed vpopmail (inter7). 
During compiling files for vchkpw authorization compiler does not find vauth.h files.
There are correct include paths!
After fixing #include directive in files, compilation ends with success, but new error occurs during linking -> no library vpopmail! -> library path is correct !  
After fixing linkage problems in *.dep files installation ends with success. But authdaemond after few authorization locks, and for correct work I have to restart him. 
	Fix scripts which check system configuration