Subject: pkg/18368: KDevelop needs autoconf-devel to create projects
To: None <>
From: Julio Merino <>
List: netbsd-bugs
Date: 09/22/2002 00:34:13
>Number:         18368
>Category:       pkg
>Synopsis:       KDevelop needs autoconf-devel to create projects
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Sep 21 15:34:01 PDT 2002
>Originator:     Julio Merino
>Release:        NetBSD 1.6H
System: NetBSD darkstar.local 1.6H NetBSD 1.6H (DARKSTAR) #16: Fri Sep 20 11:10:50 CEST 2002 jmmv@darkstar.local:/var/build/kernel/DARKSTAR i386
Architecture: i386
Machine: i386
	Project created with a recent KDevelop (the one in pkgsrc) REQUIRE
	the version of Autoconf to be 2.52 or higher.

	The problem in the package is the following: we currently DEPEND
	on devel/automake. Automake depends in turn in autoconf OR
	autoconf-devel. Therefore, if you had autoconf 2.13 installed when
	KDevelop is built, it is registered against autoconf 2.13. You can't
	remove this version of autoconf without breaking dependancies.
	I suppose that if you have autoconf-devel installed while building
	KDevelop, everything is ok.

	I do not know which is the proper solution. Making KDevelop depend
	strictly on Autoconf 2.52 by default sounds too drastic to me.
	Maybe we should not add a DEPENDS line in the makefile and then show
	a MESSAGE to the user recommending him to install autoconf-devel
	by hand (in case he wants to switch it by autoconf 2.13 sometime
	to build any other package).
	cd /usr/pkgsrc/devel/autoconf && make install # (not autoconf-devel)
	cd /usr/pkgsrc/devel/kdevelop && make install
	Project -> New -> select something -> autoconf breaks.
	Not sure.