Subject: pkg/18304: [PATCH] vorbis-tools lacks dependency on libiconv
To: None <>
From: None <richards+netbsd@CS.Princeton.EDU>
List: netbsd-bugs
Date: 09/16/2002 07:50:24
>Number:         18304
>Category:       pkg
>Synopsis:       [PATCH] vorbis-tools lacks dependency on libiconv
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Sep 16 04:51:00 PDT 2002
>Originator:     Christopher Richards
>Release:        NetBSD 1.6
System: NetBSD zembla.CS.Princeton.EDU 1.6 NetBSD 1.6 (GENERIC_LAPTOP) #0: Sun Sep 8 19:55:58 UTC 2002 i386
Architecture: i386
Machine: i386
	Ogg Vorbis files store text data in UTF-8 format, but the current
	vorbis-tools package builds without support for converting from
	the current locale's encoding to UTF-8.
	cd /usr/pkgsrc/audio/vorbis-tools; make install
	Patch follows:
diff -u pkgsrc/audio/vorbis-tools/Makefile pkgsrc/audio/vorbis-tools.NEW/Makefile
--- pkgsrc/audio/vorbis-tools/Makefile	Thu Sep  5 17:03:49 2002
+++ pkgsrc/audio/vorbis-tools.NEW/Makefile	Mon Sep 16 06:04:10 2002
@@ -27,6 +27,7 @@
 PTHREAD_OPTS+=	require
 .include "../../audio/libao/"
+.include "../../converters/libiconv/"
 .include "../../audio/libogg/"
 .include "../../audio/libvorbis/"
 .include "../../www/curl/"