Subject: pkg/18245: ftp site for 1.5/i386 has XFree86-4.x.x packages
To: None <>
From: None <>
List: netbsd-bugs
Date: 09/09/2002 16:40:00
>Number:         18245
>Category:       pkg
>Synopsis:       1.5.3 packages shouldn't be built against XFree86-4.x.x
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Mon Sep 09 16:40:01 PDT 2002
>Release:        NetBSD 1.5.3
System: NetBSD 1.5.3 NetBSD 1.5.3 (JCR-1.5-20020723) #0: Tue Jul 23 15:18:22 PDT 2002 i386
Architecture: i386
Machine: i386
I have had a couple PRs and I often see emails about problems
with binary packages for 1.5.x built against XFree86-4.x.x.
For example,
xfig- available from requires (because built under XFree86-4.x.x).

And sodipodi and evolution want
Use default XFree86 with 1.5.x.
Then successfully install various binary packatges for 1.5.x from
NetBSD's official FTP site.
Preferably rebuild and repackage all the problem X packages
under default XFree86 so they will have proper dependencies.

Or have separate download directory that is
named XFree86-4.

Or remove them so they aren't used.