Subject: pkg/18211: qt-3.0.5 crashes
To: None <>
From: None <>
List: netbsd-bugs
Date: 09/07/2002 03:09:31
>Number:         18211
>Category:       pkg
>Synopsis:       qt-3.0.5 always crashed at about the stage of opening a main window
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Sep 06 22:57:00 PDT 2002
>Release:        NetBSD 1.5.3
System: NetBSD gussie.hclsmith 1.5.3 NetBSD 1.5.3 (GUSSIE) #0: Sat Aug 3 15:25:36 ADT 2002 kwantus@gussie.hclsmith:/mnt/B/hclsmith/usr/src/sys/arch/i386/compile/GUSSIE i386
Architecture: i386
Machine: i386
	I've struggled for about a week to get KDE-3.0.3 working. Shuffling
	bits and pieces around it seems to be a crash in qt3-libs-3.0.5 at just
	about the time a main window opens.
	try building up to kdebase3-3.0.5 with just the gcc-2.91.66 bundled
	in NetBSD-1.5.3/i386 instead of th gcc-2.95.3 pkg
	I don't know if there was some change in the pkgsrc in the last day or
	two, but I seem to have improved things after speculatively installing
	gcc-2.95.3 - i just got a 3.0.4 konsole to run with qt3-libs-3.0.5,
	which it wouldn't do before. It's possible qt3-libs etc requires
	(BTW why isn't the gcc in the system compiler set more current?
	I know I'd said I'd given up on KDE-3.0.3 but I couldn't resist --
	had this one last idea after stumbling upon the gcc pkg)