Subject: pkg/18199: buildlink2 may not work with pkgsrc under /usr/local
To: None <>
From: None <>
List: netbsd-bugs
Date: 09/06/2002 07:55:43
>Number:         18199
>Category:       pkg
>Synopsis:       buildlink2 may not work with pkgsrc under /usr/local
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Sep 06 07:56:00 PDT 2002
>Release:        NetBSD 1.5.3
System: NetBSD 1.5.3 NetBSD 1.5.3 (JCR-1.5-20020723) #0: Tue Jul 23 15:18:22 PDT 2002 i386
Architecture: i386
Machine: i386
I updated new pkgsrc via cvs a few days ago.

And now a few packages won't build. (This is 1.5.3/i386.)

Each time, I reverted to previous before Aug 24 (buildlink2) changes, they
have worked. This included openldap, libxslt, and qt2-libs-2.3.1nb2.

For example, with qt2-libs, I did:
 cvs update -d -P -D "24 Aug 2002" x11/qt2-libs
(before buildlink2) and it built fine.

(By the way, back in March, I had similar buildlink issues and I
was told that /usr/pkgsrc shouldn't be under /usr/pkg -- it can
anywhere else. And that did fix my problem then.)

Place your /usr/pkgsrc under /usr/local/pkgsrc.
And try a package that has buildlink2-ized.
J. Lam asked me to PR this as a reminder and to track status
of fix.