Subject: Re: pkg/17994: Make www/mozilla depend on autoconf 2.13 *only*
To: None <>
From: Greg A. Woods <>
List: netbsd-bugs
Date: 08/19/2002 15:58:43
[ On Monday, August 19, 2002 at 21:51:36 (+0200), Julio Merino wrote: ]
> Subject: pkg/17994: Make www/mozilla depend on autoconf 2.13 *only*
> 	The www/mozilla package specifies a dependancy as autoconf>=2.13.
> 	I had autoconf 2.53 installed before building mozilla and the
> 	pre-configure step fails miserably. Installing the old version
> 	of autoconf solved the problem.
> 	In summary, mozilla does not work with autoconf-devel. It must be
> 	built with 2.13, if I'm right...

True enough -- however the patch that requires mozilla to be
re-autoconf'ed is only necessary on NetBSD/alpha.  Hmmm... except for
the new PTHREADS support I see....

The proper long-term fix is of course to use the "auto*-old" packages I
submitted in PR#17018, and to make the mozilla build use them (at least
for alpha).  (and to ask the mozilla developers when they'll finally get
around to upgrading their auto* tools!  ;-)

								Greg A. Woods

+1 416 218-0098;            <>;           <>
Planix, Inc. <>; VE3TCP; Secrets of the Weird <>