Subject: pkg/17994: Make www/mozilla depend on autoconf 2.13 *only*
To: None <>
From: Julio Merino <>
List: netbsd-bugs
Date: 08/19/2002 21:51:36
>Number:         17994
>Category:       pkg
>Synopsis:       Make www/mozilla depend on autoconf 2.13 *only*
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Aug 19 12:50:00 PDT 2002
>Originator:     Julio Merino
>Release:        NetBSD 1.6F
System: NetBSD darkstar.local 1.6F NetBSD 1.6F (DARKSTAR) #7: Mon Aug 19 13:46:31 CEST 2002 jmmv@darkstar.local:/var/build/kernel/DARKSTAR i386
Architecture: i386
Machine: i386
	The www/mozilla package specifies a dependancy as autoconf>=2.13.
	I had autoconf 2.53 installed before building mozilla and the
	pre-configure step fails miserably. Installing the old version
	of autoconf solved the problem.

	In summary, mozilla does not work with autoconf-devel. It must be
	built with 2.13, if I'm right...
	cd /usr/pkgsrc/devel/autoconf-devel
	make install
	cd ../../www/mozilla
	make install

Index: Makefile
RCS file: /pub/NetBSD-CVS/pkgsrc/www/mozilla/Makefile,v
retrieving revision 1.96
diff -u -r1.96 Makefile
--- Makefile	2002/08/02 05:40:48	1.96
+++ Makefile	2002/08/19 19:44:18
@@ -14,7 +14,7 @@
 COMMENT=	Open-source version of the Netscape browser
 BUILD_DEPENDS+=	zip>=2.3:../../archivers/zip
-BUILD_DEPENDS+=	autoconf>=2.13:../../devel/autoconf
+BUILD_DEPENDS+=	autoconf=2.13:../../devel/autoconf
 USE_PERL5=	build