Subject: kern/17948: ulpt switches to 'printer offline' in 1.6_BETA5
To: None <>
From: None <>
List: netbsd-bugs
Date: 08/15/2002 10:11:21
>Number:         17948
>Category:       kern
>Synopsis:       ulpt switches to 'printer offline' in 1.6_BETA5
>Confidential:   no
>Severity:       non-critical
>Priority:       high
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Aug 15 02:12:01 PDT 2002
>Originator:     David Brownlee
>Release:        NetBSD 1.6_BETA5
System: NetBSD 1.6_BETA5 NetBSD 1.6_BETA5 (_F1_INTERNAL_) #0: Thu Aug 8 19:12:35 BST 2002 i386
Architecture: i386
Machine: i386
	After upgrading a couple of machines from 1.5.3 to 1.6_BETA5
	problems started with the usb->printer cable

    ulpt0 at uhub0 port 1 configuration 1 interface 0
    ulpt0: Belkin Components product 0x0002, rev 1.00/1.04, addr 2, iclass 7/1
    ulpt0: using bi-directional mode

        It worked fine under 1.5.3, but under 1.6 it sometimes seems to
        'go to sleep', recording the printer as offline and only
        unplugging and reinserting the usb cable will fix it. On one
        machine that doesn't even work - it gives:
        'uhub0: device problem, disabling port 2'

        I've tried it with a full 1.6 installation and a 1.6 kernel
        with 1.5 userland so I think that reasonably ties it to a
        kernel rather than an lpd issue.

	We have at least one other person seeing a similar problem, and
	someone on 1.5W without, but its unknown if the working case is
	kernel or hardware difference.

	Print via a usb->printer adaptor. Have it fail after some random time.