Subject: pkg/17671: New for devel/libmpeg3
To: None <>
From: Julio Merino <>
List: netbsd-bugs
Date: 07/21/2002 23:51:09
>Number:         17671
>Category:       pkg
>Synopsis:       New for devel/libmpeg3
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sun Jul 21 14:50:00 PDT 2002
>Originator:     Julio Merino
>Release:        NetBSD 1.6D
System: NetBSD darkstar.local 1.6D NetBSD 1.6D (DARKSTAR) #2: Wed Jul 17 19:45:32 CEST 2002 jmmv@darkstar.local:/var/build/kernel/DARKSTAR i386
Architecture: i386
Machine: i386
	This adds a file for the devel/libmpeg3 package.
	The only package dependant on this library (for now) is audio/audacity.
	The update to 1.0.0 (which I'm working on) will use this

	You should solve pkg/17670 before adding this file. If
	not (because you think that change is wrong), change the threading
	stuff and the pkg revision of the dependancy.

# $NetBSD$
# This Makefile fragment is included by packages that use the library
# provided by libmpeg3.
# To use this Makefile fragment, simply:
# (1) Optionally define BUILDLINK_DEPENDS.libmpeg3 to the dependency
#     pattern for the version of libmpeg3 desired.
# (2) Include this Makefile fragment in the package Makefile,
# (3) Add ${BUILDLINK_DIR}/include to the front of the C preprocessor's header
#     search path, and
# (4) Add ${BUILDLINK_DIR}/lib to the front of the linker's library search
#     path.


.include "../../mk/"

BUILDLINK_DEPENDS.libmpeg3?=	libmpeg3>=1.3nb2
DEPENDS+=	${BUILDLINK_DEPENDS.libmpeg3}:../../devel/libmpeg3

BUILDLINK_FILES.libmpeg3=	include/mpeg3/*
BUILDLINK_FILES.libmpeg3+=	lib/libmpeg3.a

USE_PTHREAD=	native pth

.include "../../mk/"
.include "../../mk/"

BUILDLINK_TARGETS.libmpeg3=	libmpeg3-buildlink

pre-configure: ${BUILDLINK_TARGETS.libmpeg3}
libmpeg3-buildlink: _BUILDLINK_USE