Subject: pkg/17563: cups-1.1.14nb1 from pkgsrc fails to compile on Mac 68040 (NetBSD 1.6_BETA4)
To: None <>
From: None <>
List: netbsd-bugs
Date: 07/11/2002 11:59:28
>Number:         17563
>Category:       pkg
>Synopsis:       cups-1.1.14nb1 from pkgsrc fails to compile on Mac 68040 (NetBSD 1.6_BETA4)
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Jul 11 12:00:01 PDT 2002
>Originator:     Tom Jernigan
>Release:        NetBSD 1.6_BETA4
Oak Ridge National Laboratory
NetBSD emac-ornl02 1.6_BETA4 NetBSD 1.6_BETA4 (GENERIC) #0: Mon Jul  8 09:20:26 UTC 2002 mac68k
make package in /usr/pkgsrc/print/cups fails with the error:
Compiling GfxFont.cxx...
cc -Wall -fPIC -O2 -I/usr/pkgsrc/print/cups/work/.buildlink/include -I/usr/pkgsrc/print/cups/work/.buildlink/include -O2 -m68040 -I.. -c GfxF
ont.cxx  -fPIC -DPIC -o .libs/GfxFont.o
cc1plus in malloc(): error: brk(2) failed [internal error]
In file included from GfxFont.cxx:38:
CNS13CMapInfo.h:28831: Internal compiler error.
CNS13CMapInfo.h:28831: Please submit a full bug report.
CNS13CMapInfo.h:28831: See <URL:> for instructions.
gmake[1]: *** [GfxFont.o] Error 1
gmake: *** [all] Error 1
*** Error code 2

make: stopped in /usr/pkgsrc/print/cups
*** Error code 1

make: stopped in /usr/pkgsrc/print/cups
emac-ornl02: {70} 

I installed pkgsrc via sup. The /usr/sup/current/when.pkgsrc file is:
(Jul 9, I think)

My /etc/mk.conf file is:

However, under NetBSD 1.6Beta2, I tried it with no /etc/mk.conf file and got the same failure.

I tried to compile that particular program with both g++ and c++ (mindless replaced cc with g++ and c++ in the failed compile line) following a suggestion I got on the port_mac68k list, but both failed with the same error.

I was successful at making this same package on this same machine using NetBSD1.5

cd /usr/pkgsrc/print/cups