Subject: install/17223: sysinst seg faults during pax, netbsd 1.6 2002-05-30
To: None <>
From: None <>
List: netbsd-bugs
Date: 06/11/2002 18:27:16
>Number:         17223
>Category:       install
>Synopsis:       sysinst seg faults during pax, netbsd 1.6 2002-05-30
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 11 18:28:01 PDT 2002
>Originator:     jcline at ieee dot org
>Release:        netbsd 1.6_beta2 20020530
Continuing saga of installing netbsd on every PC in sight...

IBM thinkpad laptop, model 600X, 11 gig drive split in two: first partition is Win9x, second 8gig partition is for netbsd.

Tried to install netbsd via two methods:
 1. tried netbsd 1.6 20020530 generic kernel floppies; failed as below
 2. tried netbsd 1.6 20020530 generic laptop floppies; failed as below
 3. tried generic laptop floppies for 1.5.2-release, this install went fine and now seems to be running.

When 1.6 install fails, it is in the process of running pax on some of the tgz's it has ftp'ed into /usr/INSTALL.  Two different attempts produced seg faults during different files, I think the first time it was in man.tgz and the second time it was in games.tgz.

--------- dmesg after installing 1.5.2 -------------------------

NetBSD 1.5.2 (GENERIC_LAPTOP) #3: Sat Aug 18 23:43:41 CEST 2001
cpu0: Intel Pentium III (Coppermine) (686-class), 498.29 MHz
total memory = 127 MB
avail memory = 113 MB
using 1656 buffers containing 6624 KB of memory
BIOS32 rev. 0 found at 0xfd820
PCI BIOS rev. 2.1 found at 0xfd880
pcibios: config mechanism [1][x], special cycles [1][x], last bus 7
PCI IRQ Routing Table rev. 1.0 found at 0xf9d00, size 128 bytes (6 entries)
PCI Interrupt Router at 000:07:0
PCI Exclusive IRQs: 11
  device vendor product pin PIRQ IRQ stage
000:02:0 0x104c 0xac1b   A  0x00  11  0    already assigned
000:02:1 0x104c 0xac1b   B  0x01  11  0    already assigned
000:03:0 0x11c1 0x0449   A  0x02  11  0    already assigned
000:06:0 0x1013 0x6003   A  0x00  11  0    already assigned
000:07:2 0x8086 0x7112   D  0x03  11  0    already assigned
001:00:0 0x10c8 0x0006   A  0x00  11  0    already assigned
PCI bridge 0: primary 0, secondary 1, subordinate 1
PCI bridge 1: primary 0, secondary 2, subordinate 2
PCI bridge 2: primary 0, secondary 3, subordinate 3
PCI bus #3 is the last bus
[System BIOS Setting]-----------------------
  device vendor product
  register space address    size
000:00:0 0x8086 0x7190 
	10h mem  0x40000000 0x04000000
000:01:0 0x8086 0x7191 
000:02:0 0x104c 0xac1b 
	10h mem  0x50103000 0x00001000
000:02:1 0x104c 0xac1b 
	10h mem  0x50102000 0x00001000
000:03:0 0x11c1 0x0449 
	10h mem  0x50101000 0x00000100
	14h port 0x00004500 0x00000008
	18h port 0x00004400 0x00000100
000:06:0 0x1013 0x6003 
	10h mem  0x50100000 0x00001000
	14h mem  0x50000000 0x00100000
000:07:0 0x8086 0x7110 
000:07:1 0x8086 0x7111 
	20h port 0x0000fcf0 0x00000010
000:07:2 0x8086 0x7112 
	20h port 0x00004000 0x00000020
000:07:3 0x8086 0x7113 
001:00:0 0x10c8 0x0006 
	10h mem  0xe0000000 0x02000000
	14h mem  0x70000000 0x00400000
	18h mem  0x70400000 0x00100000
--------------------------[  0 devices bogus]
 Physical memory end: 0x07fcd000
 PCI memory mapped I/O space start: 0x08000000
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82443BX Host Bridge/Controller (rev. 0x03)
ppb0 at pci0 dev 1 function 0: Intel 82443BX AGP Interface (rev. 0x03)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled
vga1 at pci1 dev 0 function 0: Neomagic MagicMedia 256ZX VGA (rev. 0x00)
wsdisplay0 at vga1: console (80x25, vt100 emulation)
cbb0 at pci0 dev 2 function 0: Texas Instruments PCI1450 PCI-CardBus Bridge (rev. 0x03)
cbb1 at pci0 dev 2 function 1: Texas Instruments PCI1450 PCI-CardBus Bridge (rev. 0x03)
AT&T Microelectronics LTMODEM (miscellaneous communications, revision 0x01) at pci0 dev 3 function 0 not configured
clcs0 at pci0 dev 6 function 0: Cirrus Logic CS4280 CrystalClear Audio Interface (rev. 0x01)
clcs0: interrupting at irq 11
clcs0: Crystal CS4297A codec; headphone, 20 bit DAC, 18 bit ADC, Spatializer 3D
audio0 at clcs0: full duplex, independent
midi0 at clcs0: CS4280 MIDI UART
pcib0 at pci0 dev 7 function 0
pcib0: Intel 82371AB PCI-to-ISA Bridge (PIIX4) (rev. 0x02)
pciide0 at pci0 dev 7 function 1: Intel 82371AB IDE controller (PIIX4) (rev. 0x01)
pciide0: bus-master DMA support present
pciide0: primary channel wired to compatibility mode
wd0 at pciide0 channel 0 drive 0: <HITACHI_DK23AA-12B>
wd0: drive supports 16-sector pio transfers, lba addressing
wd0: 11509 MB, 16383 cyl, 15 head, 63 sec, 512 bytes/sect x 23572080 sectors
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 4
pciide0: primary channel interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (using DMA data transfers)
pciide0: secondary channel wired to compatibility mode
atapibus0 at pciide0 channel 1
cd0 at atapibus0 drive 0: <CRN-8241B, 1999/10/15, 1.23> type 5 cdrom removable
cd0: 32-bit data port
cd0: drive supports PIO mode 4, DMA mode 2
pciide0: secondary channel interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2 (using DMA data transfers)
uhci0 at pci0 dev 7 function 2: Intel 82371AB USB Host Controller (PIIX4) (rev. 0x01)
uhci0: interrupting at irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
Intel 82371AB Power Management Controller (PIIX4) (miscellaneous bridge, revision 0x03) at pci0 dev 7 function 3 not configured
cbb0: interrupting at irq 11
cbb0: cacheline 0x8 lattimer 0xb0
cbb0: bhlc 0x82a808 lscp 0xb0020200
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 2 device 0 cacheline 0x8, lattimer 0xb0
pcmcia0 at cardslot0
cbb1: interrupting at irq 11
cbb1: cacheline 0x8 lattimer 0xb0
cbb1: bhlc 0x82a808 lscp 0xb0030300
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 3 device 0 cacheline 0x8, lattimer 0xb0
pcmcia1 at cardslot1
isa0 at pcib0
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
lpt2 at isa0 port 0x3bc-0x3bf: polled
pcppi0 at isa0 port 0x61
midi1 at pcppi0: PC speaker
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
isapnp0: no ISA Plug 'n Play devices found
apm0 at mainbus0: Power Management spec V1.2
biomask effd netmask effd ttymask ffff
ep0 at pcmcia1 function 0: 3Com 3c574-TX 10/100Mbps Ethernet
ep0: address 00:50:04:ff:43:8c, 64KB word-wide FIFO, 1:1 Rx:Tx split
tqphy0 at ep0 phy 0: 78Q2120 10/100 media interface, rev. 10
tqphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs
wsdisplay0: screen 1 added (80x25, vt100 emulation)
wsdisplay0: screen 2 added (80x25, vt100 emulation)
wsdisplay0: screen 3 added (80x25, vt100 emulation)
wsdisplay0: screen 4 added (80x25, vt100 emulation)
wsmux1: connecting to wsdisplay0


------------------ dmesg for netbsd 1.6 ------------------------


1. get 1.6 beta 20020530 floppies, either generic or generic-laptop
2. boot on ibm thinkpad laptop 600X, install on 2nd partition
3. select sets, ftp install from intranet via pcmcia, ep0 
4. download finishes, pax begins running, it seg faults while unpacking.

Repeat process for 1.5.2-release using laptop kernel, it works fine.

I don't have a fix, however if anyone wants specific debug info, I can try it again.