Subject: kern/16478: USB-printer can not print because of device problems
To: None <>
From: None <>
List: netbsd-bugs
Date: 04/24/2002 15:33:11
>Number:         16478
>Category:       kern
>Synopsis:       USB-printer can not print because of device problems
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Apr 24 06:34:00 PDT 2002
>Originator:     Bjoern Labitzke
>Release:        NetBSD 1.5ZC -current from April 23rd 2002
Bjoern Labitzke  <>
   Use GPG! (Don't you use envelopes for your letters?)
System: NetBSD 1.5ZC NetBSD 1.5ZC (LABITZKE) #827: Tue Apr 23 03:03:20 CEST 2002 i386
Architecture: i386
Machine: i386
I tried to print something from ghostscript to ulpt0 and got errors.
As the same document prints fine on lpt0 and lpa0 and USB reports
problems, I think the problem lies there. After using "usbdebug 5" I
got the following outputs on the console:

After switching on the printer:
ulpt0 at uhub0 port 2 configuration 1 interface 0
ulpt0: Brother Industries HL-1050 laser printer, rev 1.00/1.00, addr 2, iclass 7/1
ulpt0: using bi-directional mode

Then I tried to print. But it failed while spewing out the following:
usb_event_thread: woke up
uhub_disconnect: up=0xc060c5c0 dev=0xc07afd80 port=2
usb_disconnect_port: disconnect subdevs
ulpt0: at uhub0 port 2 (addr 2) disconnected
usb_detach_wait: waiting for ulpt0
usb_detach_wakeup: for ulpt0
usb_detach_wait: ulpt0 done
ulpt0 detached
usbd_ar_pipe: pipe=0xc07d1700
usb_event_thread: woke up
usb_event_thread: woke up
usbd_reset_port: port 2 reset done, error=NORMAL_COMPLETION
usbd_new_device bus=0xc064c000 port=2 depth=1 speed=2
usbd_setup_pipe: dev=0xc083d580 iface=0x0 ep=0xc083d5a4 pipe=0xc083d584
usbd_get_desc: type=1, index=0, len=8
usbd_new_device: adding unit addr=2, rev=100, class=0, subclass=0, protocol=0, maxpacket=8, len=18, speed=2
usbd_get_desc: type=1, index=0, len=18
usbd_new_device: new dev (addr 2), dev=0xc083d580, parent=0xc0640440
usbd_probe_and_attach: trying device specific drivers
usbd_probe_and_attach: no device specific driver found
usbd_probe_and_attach: looping over 1 configurations
usbd_probe_and_attach: trying config idx=0
usbd_get_config_desc: confidx=0
usbd_get_desc: type=2, index=0, len=9
usbd_get_desc: type=2, index=0, len=32
usbd_set_config_index: (addr 1) cno=2 attr=0x40, selfpowered=1, power=0
usbd_set_config_index: set config 1
usbd_fill_iface_data: ifaceidx=0 altidx=0
usbd_find_idesc: idx=0(-1) altidx=0(0) len=9 type=2
usbd_find_idesc: idx=0(-1) altidx=0(0) len=9 type=4
usbd_fill_iface_data: found idesc nendpt=2
usbd_fill_iface_data: bad descriptor(s): 0 length
uhub0: port 2, set config at addr 2 failed, error=INVAL
usbd_remove_device: 0xc083d580
usbd_ar_pipe: pipe=0xc07beb00
uhub_explore: usb_new_device failed, error=INVAL
uhub0: device problem, disabling port 2

(At least I get those errors instead of panicing the kernel, which
happened a few months ago regularly. In the mean time I used lpt0 and
forgot about the problem.)
Use a Brother HL-1050 with a -current i386 system and try to print.
No idea.