Subject: pkg/16343: print/lilypond fails to build with older bison (1.28)
To: None <>
From: None <>
List: netbsd-bugs
Date: 04/13/2002 16:53:37
>Number:         16343
>Category:       pkg
>Synopsis:       print/lilypond fails to build with older bison (1.28)
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Apr 13 15:54:00 PDT 2002
>Originator:     Jim Bernard
>Release:        NetBSD 1.5ZC
System: NetBSD zoo 1.5ZB NetBSD 1.5ZB (ZOO-$Revision: 1.70 $) #0: Sun Mar 10 14:35:50 MST 2002 jim@roc:/wd1/var/tmp/compile/sys/arch/i386/compile/ZOO i386
Architecture: i386
Machine: i386
	The print/lilypond package uses bison as part of the build process,
	and if the installed bison is 1.28 (the current version in pkgsrc
	is 1.35), the build fails.  I don't have the failure message now, but
	I think I can supply a good approximation.  The successful build
	with bison-1.35 produced the following messages:

	  bison -d parser.yy
	  parser.yy:1385: warning: previous rule lacks an ending `;'
	  parser.yy contains 4 shift/reduce conflicts.
	  mv out/parser.hh

	It was at this stage that the build with bison-1.28 failed,
	complaining of "no such file or directory".  As I recall, the
	name of the file it was trying to mv was "parser.hh", not
	"", and that must have been the file that didn't

	Try to build lilypond with bison-1.28 installed.

	BUILD_DEPENDS+= bison>=1.35:../../devel/bison, I guess.