Subject: bin/16292: tcsetpgrp errors after several "work"
To: None <>
From: None <>
List: netbsd-bugs
Date: 04/10/2002 21:00:52
>Number:         16292
>Category:       bin
>Synopsis:       tcsetpgrp errors after several "work"
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Apr 10 12:00:01 PDT 2002
>Originator:     Julio Merino
>Release:        NetBSD 1.5ZC (sources of 2002/04/10)
System: NetBSD darkstar 1.5ZC NetBSD 1.5ZC (DARKSTAR) #3: Sat Apr 6 17:36:25 CEST 2002 root@darkstar:/home/archive/NetBSD/src/sys/arch/i386/compile/DARKSTAR i386
Architecture: i386
Machine: i386
	The shell gives tcsetpgrp errors after doing some work. I've been
	checking and it seems fairly random. An example of the problem:

	I'm in X-Window and open a xterm with /bin/sh:

	/home/juli$ vim .Xresources
	/home/juli$ xrdb .Xresources
	/home/juli$ vim .Xresources
	tcsetpgrp failed, errno=25
	tcsetpgrp failed, errno=25

	All subsequent commands fail miserably like this. I've been
	talking with other people and the problem seems to arise also with
	csh. Although, I used zsh for several weeks before and never
	encountered this problem.

	To solve the problem (temporary) I have to close and reopen the
	xterm. After that, everything works fine.
	As stated, the problem seems to be fairly random and it's hard to
	reproduce. I've tried repeating the same work session as exposed
	above, with no errors.