Subject: pkg/15158: squirrelmail calls out php-4.0.X, while www/php is 4.1.1
To: None <>
From: None <>
List: netbsd-bugs
Date: 01/06/2002 21:56:39
>Number:         15158
>Category:       pkg
>Synopsis:       squirrelmail calls out php-4.0.X, while www/php is 4.1.1
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jan 06 19:57:00 PST 2002
>Originator:     Eric Schnoebelen
>Release:        2002-01-06
	Central Iowa (Model) Railroad
System: NetBSD 1.5.3_ALPHA NetBSD 1.5.3_ALPHA (MILO) #8: Sun Dec 16 23:48:34 CST 2001 alpha

	squirrelmail calls out php-4.0.[X>4], while www/php is 4.1.1.
	This means that squirrel mail _always_ re-installs php when the
	installed version is 4.1.1 (or later.)  Not nice.

	cd $PKGSRCDIR/mail/squirrelmail; make update
Index: Makefile
RCS file: /cvsroot/pkgsrc/mail/squirrelmail/Makefile,v
retrieving revision 1.18
diff -u -b -w -b -u -w -r1.18 Makefile
--- Makefile	2002/01/02 11:57:01	1.18
+++ Makefile	2002/01/07 03:29:45
@@ -11,8 +11,8 @@
 COMMENT=	PHP4 webmail package
-DEPENDS+=	php-4.0.[6-9]*:../../www/php4
-DEPENDS+=	php-session-4.0.[6-9]*:../../devel/php4-session
+DEPENDS+=	php>=4.0.[6-9]*:../../www/php4
+DEPENDS+=	php-session>=4.0.[6-9]*:../../devel/php4-session
 USE_PERL5=	# defined
 NO_CONFIGURE=	# defined