Subject: port-sparc64/15150: assertion failure in sparc64 ld.elf_so
To: None <>
From: None <>
List: netbsd-bugs
Date: 01/05/2002 20:43:40
>Number:         15150
>Category:       port-sparc64
>Synopsis:       assertion failure in sparc64 ld.elf_so
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    port-sparc64-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jan 05 11:44:00 PST 2002
>Originator:     Jarle Greipsland
>Release:        NetBSD 1.5ZA
System: NetBSD 1.5ZA NetBSD 1.5ZA (OMO) #16: Wed Jan 2 10:52:47 CET 2002 sparc64
Architecture: sparc64
Machine: sparc64
I just tried to build the net/tcl-scotty application from a -current
pkgsrc tree.  At some point during the installation the scotty program
itself is used to generate an auto index of library modules in the
target directory.  This operation failed with the error message:

assertion "ELF_R_TYPE(rela->r_info) == R_TYPE(JMP_SLOT)
" failed: file "/usr/src/libexec/ld.elf_so/arch/sparc64/mdreloc.c", line 364
Abort trap - core dumped

Indeed, any attempts at executing the scotty binary fails with the
same error message.

I'm not sure that port-sparc64 is really the right category for this
report (pkg or toolchain being other obvious candidates), so feel
free to recategorize it.


Try installing the net/tcl-scotty application from pkgsrc on a -current
sparc64 system.