Subject: Re: kern/14007: uncorrectable data error reading fsbn -- problems
To: None <>
From: None <>
List: netbsd-bugs
Date: 09/23/2001 10:59:10
From: Luke Mewburn <>
Date: Sat, 22 Sep 2001 13:46:56 +1000

> On Fri, Sep 21, 2001 at 12:06:59PM +0200, Bjoern Labitzke wrote:
> > IIRC the tool is in dft-v210.exe. This program for Windows creates a
> > bootable disk. The same is available for Linux, but I haven't tried
> > that.
> The `Linux' program is just a 1.44MB floppy sized image, which you
> copy to a floppy under NetBSD using something like:
> 	dd if=dft-vt210.bin of=/dev/rfd0a bs=18

Ok, I've tried the program -- I guess 'dft' stands for 'Drive Fitness

FWIW, the command I used to make the floppy was:

  dd if=dft-v210img.bin of=/dev/rsd0d bs=18k

as I was using the USB floppy drive.

The basic test gave the following result:

  One or more bad sectors found
  Return code: 0x70
  Failure code: 0x70 - Defective Device
  Additional: 0x77
  Technical Result Code for RMA: 7077FC11

Then DFT recommended that I erase the drive, so since I still had
another hard disk with the original problem, I figured I'd go ahead as
I can do tests on the other drive.  [ Actually, the results above are
those from the second hard disk that I didn't erase -- I think the
results were the same (I'm sure up through the return code, but not
the rest). ]

DFT Error Code 0x70 has the following entry in 'Drive Fitness Test
Usage Instructions':

  Device defective.  

  A general hard disk drive problem was detected. You can run the
  "Erase Disk" utility. If a subsequent test fails again, the drive is
  defective and should be replaced.

During the erasure procedure, I heard the same kind of unpleasant
sound I heard while getting the "uncorrectable data error" under
NetBSD.  Shortly after the unpleasant sound, I got the impression that
the erasure procedure had halted (progress bar was not changing any
more).  However, that conclusion seemed to be in error as eventually
the erasure procedure completed.  Subsequent tests (both quick and
advanced) found no errors.  So, may be I have a usable hard drive
again...I'll try a clean install when I'm back in an environment with
decent bandwidth.

BTW, I didn't notice any temperature tests [1], but a different tool,
the "Feature Tool", seems to contain a temperature test.
Unfortunately, according to related documentation, the temperature
test is not supported for the model of hard drive in question (the
DARA series).

My Ultra-DMA-disabled NetBSD installation seems to be operating
smoothly so far, but it's not using the same hard disk model.

[1] May be the 'Exerciser Test' contains a temperature test, but I
    haven't tried this test yet.  I'm planning to try this test later.