Subject: port-sparc64/13839: can not build working
To: None <>
From: None <>
List: netbsd-bugs
Date: 09/01/2001 08:16:01
>Number:         13839
>Category:       port-sparc64
>Synopsis:       can not build working
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    port-sparc64-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Aug 31 23:12:00 PDT 2001
>Originator:     Martin Husemann
>Release:        1.5X from Aug17 or Aug31 (see below)
System: NetBSD 1.5X NetBSD 1.5X (SETTINGSUN) #0: Fri Aug 31 22:19:32 MEST 2001 sparc64
Architecture: sparc64
Machine: sparc64

I've updated my src tree to -current on August 31 and did a make build, with

The build broke after it installed libc, every dynamic executable started
to cause alignment faults and dump core.

The same procedure worked before (last time on August 17). So I cleaned
up everything, and tried the manual way (using the August 17 toolchain)
by doing "make includes; cd lib/libc; make; make install". This failed
the same way.

Since this is a bit of a deja vu I retried the same running an older kernel,
but results where the same.

I suppose this is a toolchain issue.

Try to build current on a sparc64 machine.