Subject: pkg/13786: creates wrong wrapper script for gnome-libs/libart-config
To: None <>
From: Martin J. Laubach <>
List: netbsd-bugs
Date: 08/26/2001 02:46:43
>Number:         13786
>Category:       pkg
>Synopsis: creates wrong wrapper script for gnome-libs/libart-config
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Aug 25 17:42:00 PDT 2001
>Originator:     Martin J. Laubach
>Release:        -current
System: NetBSD 1.5X NetBSD 1.5X (TELERY) #12: Mon Aug 6 00:49:09 CEST 2001 macppc
Architecture: powerpc
Machine: macppc

  While upgrading the graphics/dia package and converting it to
buildlink, I ran into a wrongly generated libart-config wrapper

| #!/bin/sh
| echo "` $*`" | /usr/bin/sed \
|          -e "s|-I/usr/X11R6/\(lib/gnome-libs/\)|-I/home/users/mjl/netbsd/pkgsrc/
| graphics/dia/work/.buildlink/\1|g" -e "s|-I/usr/X11R6/\(include/gtk-[^/]*/\)|-I/

  It is quite obviously missing "/usr/X11R6/bin/libart-config" before
the $*, so the configure step for dia will fail. Adding that command
manually to the wrapper script makes it work all right.

  Try to compile a recent dia.

  NC. All the other wrapper scripts are generated fine, this is the
only one with problems.