Subject: pkg/13638: graphics/xli does not build with old xsrc
To: None <>
From: Martin Husemann <>
List: netbsd-bugs
Date: 08/06/2001 09:31:28
>Number:         13638
>Category:       pkg
>Synopsis:       graphics/xli does not build with old xsrc
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Aug 06 00:28:00 PDT 2001
>Originator:     Martin Husemann
>Release:        pkgsrc from August 5
System: NetBSD 1.5X NetBSD 1.5X (PORTER) #0: Fri Jul 27 16:53:44 MEST 2001 i386
Architecture: i386
Machine: i386

Trying to build graphics/xli I get:
gcc -o xli -O2 -I/usr/pkgsrc/graphics/xli/work/.buildlink/include -I/usr/pkgsrc/graphics/xli/work/.buildlink/include  -I/usr/pkgsrc/graphics/xli/work/.buildlink/include -O2 -pipe      -L/usr/pkgsrc/graphics/xli/work/.buildlink/lib -L/usr/pkgsrc/graphics/xli/work/.buildlink/lib  -Wl,-R/usr/pkg/lib -Wl,-R/usr/pkg/lib bright.o clip.o cmuwmrast.o compress.o dither.o faces.o fbm.o fill.o  g3.o gif.o halftone.o imagetypes.o img.o mac.o mcidas.o mc_tables.o merge.o misc.o new.o options.o path.o pbm.o pcx.o reduce.o jpeg.o jpeglib.o rle.o rlelib.o root.o rotate.o send.o smooth.o sunraster.o  value.o window.o xbitmap.o xli.o xpixmap.o xwd.o zio.o zoom.o ddxli.o doslib.o tga.o bmp.o pcd.o png.o -DHAVE_GUNZIP -lXext -lX11 -L../zlib -L../libpng -lpng -lz -L/usr/pkgsrc/graphics/xli/work/.buildlink/lib -L/usr/pkgsrc/graphics/xli/work/.buildlink/lib  -Wl,-R/usr/pkg/lib -Wl,-R/usr/pkg/lib  -lm   -Wl,-rpath,/usr/X11R6/lib -Wl,-rpath,/lib
/usr/bin/ld: cannot open -lXext: No such file or directory
collect2: ld returned 1 exit status
*** Error code 1


On a system using old xsrc (3.6) try to build graphics/xli.


The -lXext (and some other X libs) and the  -Wl,-rpath,/usr/X11R6/lib are
out of order. No idea why.