Subject: pkg/13346: Slight Problem with Hylafax
To: None <>
From: None <>
List: netbsd-bugs
Date: 06/30/2001 10:58:07
>Number:         13346
>Category:       pkg
>Synopsis:       faxsetup fails in obscure ways
>Confidential:   no
>Severity:       critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jun 30 08:56:00 PDT 2001
>Originator:     Dave Burgess
>Release:        NetBSD Release 1.5
Nebraska On-Ramp
System: NetBSD 1.5 NetBSD 1.5 (GENERIC) #1: Sun Nov 19 21:42:11 MET 2000 fvdl@sushi:/work/trees/netbsd-1-5/sys/arch/i386/compile/GENERIC i386

	There are at least three different problems with the HylaFAX
	faxsetup program.  

	Near line 2085, the subroutine to find the pid numbers for the
	running programs fails both tests.  I replaced the check with 
	"ps -ax | grep $1 | grep -v grep | head -1 | cut -c1-5"

	While this is clearly a Kludge, it should work for all systems.

	The other two errors are the tests for "SYSVINIT".  It's blank
	in my installation.  The tests that refer to it seem to do the
	Wrong Thing at execution time.  The clue is 'start: not found'
	near line 2210.  The "if [ -x " near there seems to be perfectly
	happy with the -x and no argument.  I enclosed the argument in
	quotation marks, and the test worked.  I did the same thing with
	the "[ -f" near line 1709.

	Install Hylafax onto a new system.  The errors are built into
	the system.  Watch for "start: not found" during the faxsetup

	See write-up.  Quotation marks fix most of the problems, and the
	changed code in the findproc function solved all of my problems.