Subject: pkg/13290: kde-2.1 binary package requires >= qt2-libs-2.3.0 not >= qt2-libs-2.2.4
To: None <>
From: None <>
List: netbsd-bugs
Date: 06/23/2001 11:43:00
>Number:         13290
>Category:       pkg
>Synopsis:       kde-2.1 binary package requires >= qt2-libs-2.3.0 not >= qt2-libs-2.2.4
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          doc-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jun 23 11:41:00 PDT 2001
>Originator:     Scott Presnell
>Release:        5/26/2001

System: NetBSD srp1 1.5V NetBSD 1.5V (PO) #1: Wed Jun 20 10:01:41 PDT 2001 root@srp4:/usr/syssrc/sys/arch/i386/compile/PO i386
Architecture: i386
Machine: i386
	When installing kde-2.1 (kdelibs-2.1) the prerequisites suggests
that a qt2-libs of 2.2.4 or greater is acceptable.  After installing all
prerequisites kdm didn't start and kde wouldn't engage because of
unresolved symbols.  These symbols were not in qt2-libs-2.2.4, but they
were in qt2-libs-2.3.0 

After installing qt2-libs-2.3.0 kdm would start.

	Attempt to install kde-2.1 from current binary package

	Advertise prerequisite >= qt2-libs-2.3.0
and patch +CONTENTS:

*** +CONTENTS.old       Sat Jun 23 11:40:55 2001
--- +CONTENTS   Sat Jun 23 11:41:29 2001
*** 33,39 ****
  @pkgdep png>=1.0.6
  @pkgdep pth>=1.3.7
  @pkgdep ptl>=2.1.7
! @pkgdep qt2-libs>=2.2.4
  @pkgdep tiff-*
  @pkgdep uulib-0.5.13
  @pkgdep watanabe-vfont-19930318
--- 33,39 ----
  @pkgdep png>=1.0.6
  @pkgdep pth>=1.3.7
  @pkgdep ptl>=2.1.7
! @pkgdep qt2-libs>=2.3.0
  @pkgdep tiff-*
  @pkgdep uulib-0.5.13
  @pkgdep watanabe-vfont-19930318