Subject: pkg/13156: pkgsrc php-4.0.5 breaks horde-2.2.5 phplib and imp-2.2.5
To: None <>
From: Rogier Krieger <>
List: netbsd-bugs
Date: 06/10/2001 21:17:30
>Number:         13156
>Category:       pkg
>Synopsis:       pkgsrc php-4.0.5 breaks horde-2.2.5 phplib and imp-2.2.5
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jun 10 14:28:01 PDT 2001
>Originator:     R. Krieger
>Release:        NetBSD 1.5
KSV Sanctus Virgilius
P2-333, NetBSD 1.5, default install, applications through pkgsrc
System: NetBSD karres 1.5 NetBSD 1.5 (GENERIC) #1: Sun Nov 19 21:42:11 MET 2000 fvdl@sushi:/work/trees/netbsd-1-5/sys/arch/i386/compile/GENERIC i386

	after an update for php4 (incl. php4-imap, php4-mysql) to 4.0.5
	through package source, I also updated horde and imp to versions
	2.2.5. Afterwards, the imp package refuses to work giving a fatal
	error on the undefined function preg_match() in (line 111).

	This is likely caused by the lack of pcre (perl compatible regex)
	support in the php4-4.0.5. Its makefile explicity wants to do
	without the pcre.

	Install and configure the default php-4.0.5 source package for usage with horde-2.2.5
	and imp-2.2.5. Whenever either the test.php3 (horde) page is opened or the imp
	system is opened, php dies with an error stating the preg_match() function is not defined. 
	Comment out the following line in www/php4/Makefile.common
		CONFIGURE_ARGS+=       --without-pcre-regex

	Recompile the php4 package and horde/imp work again.
	Installing the latest pcre-3.4 and php4-pcre packages as another way to fix things does not work.
	This gives other errors while trying to install pcre-3.4.

	For binary package users (if any for php4-4.0.5) I can't think of another fix but installing
	by modified-as-above pkgsrc.