Subject: pkg/13033: samba under 1.5
To: None <>
From: None <>
List: netbsd-bugs
Date: 05/24/2001 16:15:22
>Number:         13033
>Category:       pkg
>Synopsis:       samba uses kernel defines.
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu May 24 14:15:00 PDT 2001
>Originator:     Ron Roskens
>Release:        pkgsrc-20010523
System: NetBSD 1.4 NetBSD 1.4 (GENERIC) #0: Fri May 7 12:27:31 PDT 1999 i386

net/samba package now tries to use IPC_R, and IPC_W instead of SHM_R, and
SHM_W. Neither of those are defined for userland unless _KERNEL is defined.

cd pkgsrc/net/samba

Don't use kernel defines.