Subject: port-macppc/13022: X Window System VRAM mapping problem
To: None <>
From: None <>
List: netbsd-bugs
Date: 05/24/2001 08:40:02
>Number:         13022
>Category:       port-macppc
>Synopsis:       ATI Technologies Rage Fury MAXX AGP 4x (TMDS) VRAM mapping
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    port-macppc-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed May 23 16:40:01 PDT 2001
>Originator:     Makoto Fujiwara
>Release:        03/23/2001
System: NetBSD milano 1.5V NetBSD 1.5V (GENERIC) #1: Sun May 20 20:43:38 JST 2001 root@nazuha:/usr/src/sys/arch/macppc/compile/GENERIC macppc
Architecture: powerpc
Machine: macppc
	  With the  machine:
	PowerMac G4/AGP/350 with included video card
	ATI Technologies Rage Fury MAXX AGP 4x (TMDS) 
	ofb0: 1152 x 870, 8bpp,
	  X Window System use 1280 x 1024 screen, but actual screen 
	is 1152 x 870, resulting VRAM mapping is wrong.

	Starting X Window System with minimum setup after installation
	of 20010323 snapshot (1.5S) on this particular machine, 
	gives unorganized screen.
          (5/6) of screen showing sliced image of X
	  and I could read following text at bottom,
        ukbd_enable: ukbd0: bad call on=1 
	kbd_type = 1
	I could halt the machine, and it will leave the string
        syncing disks... 2 done

	EXIT called ok
        0 >
	Not really known, but some work arround is here:

        Before booting NetBSD, at OF level, I can tweak this problem.
        0 > dev screen
        0 > show-modes 
            will tell
        10 1152 x 870 @75Hz CURRENT
        0 > 8 set-mode
            will change to
         8 1280 x 1024 @75Hz
	0 > boot
	Then everything is OK except some portion of the X Window
        screen is out of physical screen and could not read bottom