Subject: pkg/13007: devel/boehm-gc under 1.4.3
To: None <>
From: Aaron J. Grier <>
List: netbsd-bugs
Date: 05/22/2001 22:57:39
>Number:         13007
>Category:       pkg
>Synopsis:       devel/boehm-gc does not compile under 1.4.3
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue May 22 22:57:00 PDT 2001
>Originator:     Aaron J. Grier
>Release:        1.4.3, pkgsrc -current as of 2001-05-21
poofy goof enterprises 
System: NetBSD goldberry 1.4.3A NetBSD 1.4.3A (goldberry) #0: Wed Feb 14 19:32:25 PST 2001 agrier@goldberry:/suckym/NetBSD/1.4/src/sys/arch/pmax/compile/goldberry pmax

	when compiling pkgsrc/devel/boehm-gc under 1.4.3/pmax, compilation
fails due to missing macros in /usr/include/exec_elf.h

	attempt to compile pkgsrc/devel/boehm-gc from 1.4.3/pmax
	install /usr/include/exec_elf.h and
/usr/include/machine/int_types.h from -current.  not terribly elegant,
but it does appear to work.  a better solution might be to backport the
added macros from -current to release-1-4.