Subject: pkg/13004: "sudo" package requires perl installation?
To: None <>
From: None <>
List: netbsd-bugs
Date: 05/22/2001 11:50:11
>Number:         13004
>Category:       pkg
>Synopsis:       "sudo" package requires perl installation?
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue May 22 11:49:00 PDT 2001
>Originator:     Lars Kellogg-Stedman
>Release:        NetBSD-1.5/macppc
NetBSD snowmaiden 1.5 NetBSD 1.5 (LARS_001) #4: Wed May 23 07:07:25 EDT 2001     root@snowmaiden:/usr/src/sys/arch/macppc/compile/LARS_001 macppc

I have NetBSD installed on a system with limited disk space.  I wanted to install "sudo" using the NetBSD package distribution.  Much to my surprise, "sudo" requires a complete Perl installation -- which, while frequently useful, is hardly small.

It is possible to build and install sudo without Perl.  Until Perl is part of the base install, I would avoid frivolous dependencies on it, because downloading and building it eats bandwidth, disk space, and time.